Closed
Description
The syntax to designate a family currently looks like this:
family(store_subscr, INLINE_CACHE_ENTRIES_STORE_SUBSCR) = {
STORE_SUBSCR,
STORE_SUBSCR_DICT,
STORE_SUBSCR_LIST_INT,
};
Here the store_subscr
"family name" is redundant (and in fact we even had one case where it was incorrect).
I propose to change it to be more similar to the pseudo
syntax, so it will become
family(STORE_SUBSCR, INLINE_CACHE_ENTRIES_STORE_SUBSCR) = {
STORE_SUBSCR_DICT,
STORE_SUBSCR_LIST_INT,
};
This should be a straightforward change to the parser and code generator in Tools/cases_generator.