Open
Description
Problem
Suggested in #29646 (comment)
In addition to the single-char (and in rare cases int) marker definitions, we should also support long names "o"
-> "circle"
. These long names should be supported wherever the short mnemonics are, with the exception of the fmt
string syntax in plot()
- that should still only accept single chars.
This allows more readable code marker="tri_up"
instead of marker="2"
. It also opens a route for deprecating the int markers, which create trouble for parsing/validating.
Proposed solution
The long names should mostly be the ones from the "description" column in https://matplotlib.org/devdocs/api/markers_api.html#module-matplotlib.markers, with some slight adjustments:
- "filled_plus" instead of "plus (filled)"
- do not include "nothing" - we already have more than enough no-marker definitions.