Open
Description
Problem
Looking at #25796 and #26854, it might be helpful to be able to independently set the different parts of sketch and not just as a tuple. This is motivated by wanting to make plt.xkcd
discouraged and wanting the cleanest alternative for passing in the sketch params.
Proposed solution
#25796 moves in this direction by allowing both
mpl.rcParams['path.sketch'] = (scale, length, randomness, seed)
mpl.rcParams[`path.sketch_seed'] = seed
and if we're OK w/ the other parameters getting their own rcParams then they can have a unified naming scheme. Alternatively, we can probably do the parsing so None = default
but I don't like having to remember which position is which param.