Harmonize the phrasing of "X models foo_of<Y>" #7036
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
This leaves at least two places that I don't know quite how to reword without major surgery; but it makes everything else consistent. The two places are
I started down this rabbit hole with [alg.equal], which currently says
which is obviously awkward since what it actually wants to say is that
last1, first1
andlast2, first2
modelsized_sentinel_for
— that's a weirdly reversed way of interpreting "pairwise". It now says simply "S1
modelssized_sentinel_for<I1>
"... but then I noticed all the random places where we said things like "S1
modelssized_sentinel_for<S1, I1>
" or "I1
andS1
modelsized_sentinel_for<S1, I1>
", and cleaned them up too.The style being selected-for here is:
I
modelsinput_iterator
" (not "I
modelsinput_iterator<I>
")S
modelssentinel_for<I>
" (not "S
modelssentinel_for<S, I>
"; not "S
andI
modelsentinel_for
")sentinel_for<S, I>
is modeled" (only if absolutely necessary)